Practice: Format Date Method

Hi there. Just a heads up I’m getting an error when submitting the practice problem from Imports and Libraries → Practice: Format Date Method

Ran 64 tests. Stopped after finding 1 failure:

Testing formatDate(long millis = 1) failed:
Solution returned: “1970-01-01T00:00:00.001Z”
Submission returned: “1970-01-01T00:00:00.001Z”

I am using the supplied solution from the walkthrough, but still get the same error. Thanks.


I’m having the same problem. It took me forever to find the correct library and method, then I finally got my answer to match the test output only to have it still fail :confounded:

I had the same problem on that question, and I encountered another bug later on in the same lesson that I described over here: Homework: Compare Date Strings | I have one more extra line of code but I feel like I have the bare minimum. Hope this gets fixed soon.

Sorry about that! I just looked at this and it looks like it’s fixed now. That must have been frustrating though.